I got a phone call today from Chase regarding suspicious activity on my business debt card. After a few minutes, I had learned that somehow my card was stolen along with my ATM pin along with 5 withdrawals of $500 from today and yesterday from various locations throughout California. I was worried that I would not see that money again but Chase immediately told me that I would get my money back after filing a claim.

The strange thing is that I never use my ATM card for any thing outside of depositing checks from 2 or 3 Chase ATMs in my area. I actually drove back to one of the ATMs and was looking around for a skimming device but didn’t notice anything out of the ordinary.

Back to the story, I was asked if I had access to an email to get access to a claim form. I gave them my email and was sent two emails within a few minutes with my login info.  I opened up the 2nd email which had my username with a subject of “Your Chase Customer Claims Secure Document Exchange Electronic Package is available online” and clicked on the link, which took me to https://sdx.chase.com/consumerdcx-chase_atm.

I set up my account and then logged in. I see a message waiting for me to be read, I click it and got the following message:

Sorry

A system error has occurred. Please try again, but if you continue to see this message then contact the system administrator.

I tried a number of basic troubleshooting strategies such as clearing cookies, closing browser, using Chrome, Firefox and IE on Windows, switching to my Mac laptop, tried Chrome and Firefox, then loaded up VM Fusion with a Windows XP instance. I kept getting the same screen. I even viewed the source of the page, and tried going directly to the URL the javascript function was suppose to take me to.

https://sdx.chase.com/consumerdcx-chase_atm/messages/MessageDetail?action=1&msgId=XXXXXXXX-true&listType=6&urlPrefix=http://sdx.chase.com/consumerdcx-chase_atm

No luck. I thought, maybe I’m just an idiot, why don’t I just call tech support. Of course, they told me to clear my cookies and reboot my computer. When has that seriously worked when there was an issue with a website?

I wonder that I can’t be the only one out there having the same issue. I eventually called Chase back and had them fax me the form.